Home > O Error > I O Error Err_mask 0x1

I O Error Err_mask 0x1

Contents

Having trouble installing a piece of hardware? SMP alternatives: switching to SMP code Booting processor 1/2 APIC 0x1 Initializing CPU#1 Calibrating delay using timer specific routine.. 4793.45 BogoMIPS (lpj=7986329) CPU: L1 I cache: 32K, L1 D cache: 32K CPU: L2 cache: 4096K CPU: Physical Processor ID: 0 CPU: Processor Core ID: 1 CPU1: Thermal monitoring enabled (TM2) Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz stepping 06 checking TSC synchronization [CPU#0 -> CPU#1]: passed. Easily. Comment 11 David Milburn 2009-07-01 16:36:14 EDT Looking at the error message, ata1.00: exception Emask 0x10 SAct 0x0 SErr 0x4090000 action 0xe frozen ata1.00: irq_stat 0x00400040, connection status changed ata1: SError: { PHYRdyChg 10B8B DevExch } ata1.00: cmd ea/00:00:00:00:00/00:00:00:00:00/a0 tag 0 res 40/00:8c:f8:52:23/00:00:15:00:00/40 Emask 0x10 (ATA bus error) ata1.00: status: { DRDY } According to the Sata Error Register (SErr=0x4090000), the following errors are occuring between the controller and the device resulting in the ATA bus error: PHYRdyChg- this is an internal PHY error losing communication link. 10B8B - host controller detected a decoding error DevExch - device presence status bit has changed.

Note that registered members see fewer ads, and ContentLink is completely disabled once you log in. Not usable in production either. Console: colour dummy device 80x25 console [tty0] enabled Dentry cache hash table entries: 262144 (order: 9, 2097152 bytes) Inode-cache hash table entries: 131072 (order: 8, 1048576 bytes) Checking aperture... I just have great concerns trusting my data to this controller.

Revalidation Failed (errno=-5)

H_TeXMeX_H View Public Profile View LQ Blog View Review Entries View HCL Entries View LQ Wiki Contributions Find More Posts by H_TeXMeX_H View Blog 05-14-2011, 10:07 AM #5 vibes LQ Newbie Registered: Oct 2008 Posts: 9 Original Poster Rep: ok thanks for the reply, I dont have physical access to the server but Ive emailed support asking them to check the cables and test the memory. It seems Google can't spit out the solution, should I report a bug to the kernel devs and pray that they look it up? SUCCESS!!! I've also put the LBA mark on it in bios, it did nothing.I'm running out of ideas, can anyone please suggest something - obviously not buying a new HD, it's not worth it.

It says there was an irq on line 10, and "nobody cared" ie it wasnt handled. May 13 16:52:24 server1 kernel: [ 988.581316] sd 0:0:1:0: [sda] Unhandled error code May 13 16:52:24 server1 kernel: [ 988.581319] sd 0:0:1:0: [sda] Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK May 13 16:52:24 server1 kernel: [ 988.581321] sd 0:0:1:0: [sda] CDB: Write(10): 2a 00 06 43 bb 4c 00 00 08 00 May 13 16:52:24 server1 kernel: [ 988.581328] end_request: I/O error, dev sda, sector 105102156 May 13 16:52:24 server1 kernel: [ 988.581426] sd 0:0:1:0: [sda] Unhandled error code May 13 16:52:24 server1 kernel: [ 988.581427] sd 0:0:1:0: [sda] Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK May 13 16:52:24 server1 kernel: [ 988.581430] sd 0:0:1:0: [sda] CDB: Write(10): 2a 00 06 43 dc 84 00 00 08 00 error repeats May 13 16:52:24 server1 kernel: [ 988.581434] end_request: I/O error, dev sda, sector 105110660 May 13 16:52:24 server1 kernel: [ 988.711564] ata3: hard resetting link May 13 16:52:24 server1 mysqld: 110513 16:52:24 - mysqld got signal 11 ; May 13 16:52:24 server1 mysqld: This could be because you hit a bug. The Microserver's four internal SATA slots are used for something else; these messages relate to the two eSATA links (ata5 and ata6) to the disk enclosure. Result Hostbyte Did_error Driverbyte Driver_ok In terms of appearance and dimensions it's almost identical to the Sans Digital one.

Adv Reply Quick Navigation Hardware Top Site Areas Settings Private Messages Subscriptions Who's Online Search Forums Forums Home Forums The Ubuntu Forum Community Ubuntu Official Flavours Support New to Ubuntu General Help Installation & Upgrades Hardware Desktop Environments Networking & Wireless Multimedia Software Ubuntu Studio Mythbuntu Ubuntu Specialised Support Ubuntu Phone and Tablet Ubuntu Development Version Security Virtualisation Ubuntu Servers, Cloud and Juju Server Platforms Ubuntu Cloud and Juju Gaming & Leisure Emulators Wine Development & Programming Packaging and Compiling Programs Development CD/DVD Image Testing Ubuntu Application Development Ubuntu Dev Link Forum Programming Talk Repositories & Backports Ubuntu Backports Bug Reports / Support System76 Support Apple Hardware Users Ubuntu Community Discussions Ubuntu, Linux and OS Chat Recurring Discussions Full Circle Magazine The Cafe Cafe Games Market Mobile Technology Discussions Announcements & News Weekly Newsletter Membership Applications The Fridge Discussions Forum Council Agenda Forum Feedback & Help Request a LoCo forum Resolution Centre Other Discussion and Support Other OS Support and Projects Other Operating Systems Ubuntu/Debian BASED Debian MINT Arch and derivatives Fedora/RedHat and derivatives Mandriva/Mageia Slackware and derivatives openSUSE and SUSE Linux Enterprise Mac OSX PCLinuxOS Gentoo and derivatives Windows BSD Any Other OS Other Projects Ubuntu Christian Edition Ubuntuzilla Ubuntu Translations Assistive Technology & Accessibility Art & Design Education & Science Documentation and Community Wiki Discussions Tutorials Outdated Tutorials & Tips Ubuntu Women Ubuntu LoCo Team Forums Americas LoCo Teams Argentina Team Software Hardware Comunidad Arizona Team - US Arkansas Team - US Brazil Team California Team - US Canada Team Centroamerica Team Chile Team Comunidad Hardware Software Instalación y Actualización Colombia Team - Colombia Georgia Team - US Illinois Team Indiana - US Kentucky Team - US Maine Team - US Minnesota Team - US Mississippi Team - US Nebraska Team - US New Mexico Team - US New York - US North Carolina Team - US Ohio Team - US Oklahoma Team - US Oregon Team - US Pennsylvania Team - US Peru Team Texas Team - US Uruguay Team Utah Team - US Virginia Team - US West Virginia Team - US Asia and Oceania LoCo Teams Australia Team Bangladesh Team Hong Kong Team Myanmar Team Philippine Team Singapore Team Europe, Middle East, and African (EMEA) LoCo Teams Albania Team Catalan Team Egypt Team Georgia Team Ireland Team - Ireland Kenyan Team - Kenya Kurdish Team - Kurdistan Lebanon Team Morocco Team Saudi Arabia Team Sudan Team Tunisia Team Other Forums & Teams LoCo Archive Afghanistan Team Alabama Team - US Alaska Team - US Algerian Team Andhra Pradesh Team - India Austria Team Bangalore Team Bolivia Team Cameroon Team Colorado Team - US Connecticut Team Costa Rica Team Delhi Team Ecuador Team El Salvador Team Florida Team - US Galician LoCo Team Greek team Hawaii Team - US Honduras Team Idaho Team - US Iowa Team - US Jordan Team Kansas Team - US Libya Team Louisiana Team - US Maryland Team - US Massachusetts Team Michigan Team - US Missouri Team - US Montana Team - US Namibia Team Nevada Team - US New Hampshire Team - US New Jersey Team - US Northeastern Team - US Panama Team Paraguay Team Qatar Team Quebec Team Rhode Island Team - US Senegal Team South Carolina Team - US South Dakota Team - US Switzerland Team Tamil Team - India Tennessee Team - US Trinidad & Tobago Team Uganda Team United Kingdom Team US LoCo Teams Venezuela Team Wales Team Washington DC Team - US Washington State Team - US Wisconsin Team Yemen Team Za Team - South Africa Zimbabwe Team « Previous Thread | Next Thread » Bookmarks Bookmarks Digg del.icio.us StumbleUpon Google Posting Permissions You may not post new threads You may not post replies You may not post attachments You may not edit your posts BB code is On Smilies are On [IMG] code is On [VIDEO] code is Off HTML code is Off Ubuntu Forums Code of Conduct -- Ubuntu vB4.x -- Ubuntu Mobile Style Ubuntu Forums Archive Top All times are GMT +1. vibes View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by vibes 05-14-2011, 09:08 AM #4 H_TeXMeX_H LQ Guru Registered: Oct 2005 Location: $RANDOM Distribution: slackware64 Posts: 12,928 Blog Entries: 2 Rep: Well, technically, no attribute is failing, but some are only updated with an offline test (marked "Offline"). It is also possible that this binary May 13 16:52:24 server1 kernel: [ 989.187183] ata3: SATA link up 1.5 Gbps (SStatus 113 SControl 310) May 13 16:52:24 server1 kernel: [ 989.206526] ata3.00: failed to IDENTIFY (I/O error, err_mask=0x2) May 13 16:52:24 server1 kernel: [ 989.206529] ata3.00: revalidation failed (errno=-5) May 13 16:52:28 server1 kernel: [ 992.564413] I/O error in filesystem ("dm-5") meta-data dev dm-5 block 0x1dc7e79 ("xlog_iodone") error 5 buf count 96256 May 13 16:52:28 server1 kernel: [ 992.564558] xfs_force_shutdown(dm-5,0x2) called from line 1043 of file /build/buildd-linux-2.6_2.6.32-31-amd64-vrfdM4/linux-2.6-2.6.32/debian/build/source_amd64_openvz/fs/xfs/xfs_log.c. ahci_init+0x0/0x19 [ahci] Jun 30 13:02:43 node105 kernel: [] ? __pci_register_driver+0x40/0xa0 Jun 30 13:02:43 node105 kernel: [] ?

error, file /DSDT.aml not found. Hostbyte=did_bad_target Driverbyte=driver_ok As you know, the workaround will not enter themainline only as our codes.So do you think I should revert all to the original codes? Can anyone help in figuring out whats going on? Search this Thread 05-14-2011, 07:53 AM #1 vibes LQ Newbie Registered: Oct 2008 Posts: 9 Rep: Failing harddrive?

Ata Failed To Identify (i/o Error Err_mask=0x4)

Ubuntu Ubuntu Insights Planet Ubuntu Activity Page Please read before SSO login Advanced Search Forum The Ubuntu Forum Community Ubuntu Official Flavours Support Hardware [ubuntu] ERROR: ata1.00 FAILED TO IDENTIFY Having an Issue With Posting ? click Can Micheal change the schematics in the hardwareproject? Revalidation Failed (errno=-5) I really want to fix this. Exception Emask 0x0 Sact 0x0 Serr 0x0 Action 0x6 Frozen Hope so.Any clues on how one might fix this?

If you'd like to contribute content, let us know. It's pretty slow to detect disks and spews errors in the dmesg as it does. sys_close+0x60/0xa0 Jun 30 13:02:43 node105 kernel: [] ? Click Here to receive this Complete Guide absolutely free. Smartctl Terminate Command Early Due To Bad Response To Iec Mode Page

ata_host_start+0xbd/0x190 [libata] Jun 30 13:02:43 node105 kernel: [] ? Offline #5 2008-04-15 14:10:06 gajo Member Registered: 2008-04-01 Posts: 93 Website Re: long boot due to ata recognition problems [SOLVED] I've bought a new PATA cable, even tried meddling with master/slave pins on the hard disk, tried booting it as only device, but alas to no avail. Comment 2 David Milburn 2008-08-20 09:58:09 EDT The error/recovery handling will be updated in RHEL5.3, moving this to 5.4 since to see if it remains reproducible. So anyway, plan of action: Try rebooting everything.

Problem is reproducible on all of them, so this is not bad hardware. Xfs_log_force: Error 5 Returned I haven't selected anything while doing the installation, and I'm not sure if I should have?Next, you will be asked if you need support for booting from USB devices, FireWire devices, PCMCIA devices, NFS shares, software RAID arrays, LVM2 volumes, encrypted volumes, and DSDT support.I don't think I qualify for any of those, so there is probably something else I might've missed. Tango Icons © Tango Desktop Project.

This is really something I don't know how to fix.

driver_probe_device+0x69/0x140 Jun 30 13:02:43 node105 kernel: [] ? So… I am waiting for either an advance in the device selection (I think this is too hard and a violation of their design, so won't happen) or an advance in Linux's block device caching technologies. Would be grateful for any suggestions, Thanks! Hit a curb; chewed up rim and took a chunk out of tire.

I'm torn apart between worlds. SATA device can be found while system start-up:scsi0 : pata_platformata1: PATA max PIO0 mmio cmd 0x20314020 ctl 0x2031401c irq 55ata1.00: qc timeout (cmd 0x27)ata1.00: failed to read native max address (err_mask=0x4)ata1.00: HPA support seems broken, skipping HPA handlingata1.00: configured for PIOscsi 0:0:0:0: Direct-Access ATA Hitachi HTS54161 SB4O PQ: 0 ANSI: 5sd 0:0:0:0: [sda] 312581808 512-byte hardware sectors: (160 GB/149 GiB)sd 0:0:0:0: [sda] Write Protect is offsd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUAsd 0:0:0:0: [sda] 312581808 512-byte hardware sectors: (160 GB/149 GiB)sd 0:0:0:0: [sda] Write Protect is offsd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA2. So I had to add the all_generic_ide line back to grub. Unplugging the eSATA cables entirely left the Microserver happy to boot with no issues other than all my data being missing!

It's not always the same drives that drop out, it seems completely random. CPU: Physical Processor ID: 0 CPU: Processor Core ID: 0 CPU0: Thermal monitoring enabled (TM1) SMP alternatives: switching to UP code Early unpacking initramfs... Problem with the "frozen" devices remains, regardless of boot options... it is Freeing initrd memory: 690k freed VFS: Disk quotas dquot_6.5.1 Dquot-cache hash table entries: 512 (order 0, 4096 bytes) Installing knfsd (copyright (C) 1996 [email protected]).

investigate the Sans Digital enclosure to see if I can replicate its brokenness. driver_register+0x5a/0x130 Jun 30 13:02:43 node105 kernel: [] ? Linux Plug and Play Support v0.97 (c) Adam Belay pnp: PnP ACPI init ACPI: bus type pnp registered pnp: PnP ACPI: found 16 devices ACPI: ACPI bus type pnp unregistered SCSI subsystem initialized PCI: Using ACPI for IRQ routing PCI: If a device doesn't work, try "pci=routeirq". Maybe Jeff will have some additional input regarding the SATA recovery modes leading up to the drive being disabled.

The snapshot feature is really appealing - but don't turn on quota groups with it (which you need to find disk usage) unless you're on a very new kernel, else you'll see kernel panics. This usually points to an electrical problem, I do realize you said it is reproducible on 6 different systems. Password Linux - Hardware This forum is for Hardware issues. Using local APIC timer interrupts.

The drives are Seagate NAS 4TB SATA drives. –Patrick Bergner Feb 25 '14 at 20:55 add a comment| active oldest votes Know someone who can answer? I recently wiped 7.04 and installed 8.04 on my storage/printer server. Code: uname -a Linux server1 2.6.32-5-openvz-amd64 #1 SMP Mon Mar 7 22:25:57 UTC 2011 x86_64 GNU/Linux Code: May 13 16:51:49 server1 kernel: [ 954.196601] ata1.01: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0 May 13 16:51:49 server1 kernel: [ 954.196682] ata1.01: BMDMA stat 0x66 May 13 16:51:49 server1 kernel: [ 954.196758] ata1.01: failed command: WRITE DMA May 13 16:51:49 server1 kernel: [ 954.196824] ata1.01: cmd ca/00:08:8c:7c:45/00:00:00:00:00/f6 tag 0 dma 4096 out May 13 16:51:49 server1 kernel: [ 954.196826] res 51/04:01:00:00:00/00:00:00:00:00/f0 Emask 0x21 (host bus error) May 13 16:51:49 server1 kernel: [ 954.196992] ata1.01: status: { DRDY ERR } May 13 16:51:49 server1 kernel: [ 954.197055] ata1.01: error: { ABRT } May 13 16:51:49 server1 kernel: [ 954.221136] ata1.01: configured for UDMA/100 May 13 16:51:49 server1 kernel: [ 954.221144] ata1: EH complete May 13 16:52:12 server1 kernel: [ 976.679527] ata2.01: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 May 13 16:52:12 server1 kernel: [ 976.679609] ata2.01: BMDMA stat 0x46 May 13 16:52:12 server1 kernel: [ 976.679685] ata2.01: failed command: WRITE DMA EXT May 13 16:52:12 server1 kernel: [ 976.679760] ata2.01: cmd 35/00:08:3f:c8:3d/00:00:2c:00:00/f0 tag 0 dma 4096 out May 13 16:52:12 server1 kernel: [ 976.679761] res 51/84:01:3f:c8:3d/84:00:2c:00:00/f0 Emask 0x30 (host bus error) May 13 16:52:12 server1 kernel: [ 976.679920] ata2.01: status: { DRDY ERR } May 13 16:52:12 server1 kernel: [ 976.679983] ata2.01: error: { ICRC ABRT } May 13 16:52:12 server1 kernel: [ 976.680054] ata2: soft resetting link May 13 16:52:12 server1 kernel: [ 976.862859] ata2.01: failed to IDENTIFY (I/O error, err_mask=0x2) May 13 16:52:12 server1 kernel: [ 976.862862] ata2.01: revalidation failed (errno=-5) May 13 16:52:17 server1 kernel: [ 981.825917] ata2: soft resetting link May 13 16:52:17 server1 kernel: [ 982.014926] ata2.01: configured for UDMA/100 May 13 16:52:17 server1 kernel: [ 982.014939] ata2: EH complete May 13 16:52:18 server1 kernel: [ 982.810262] ata1.01: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0 May 13 16:52:18 server1 kernel: [ 982.810390] ata1.01: BMDMA stat 0x66 May 13 16:52:18 server1 kernel: [ 982.810462] ata1.01: failed command: WRITE DMA May 13 16:52:18 server1 kernel: [ 982.810529] ata1.01: cmd ca/00:40:6d:1d:2a/00:00:00:00:00/f1 tag 0 dma 32768 out May 13 16:52:18 server1 kernel: [ 982.810530] res 51/04:01:00:00:00/00:00:00:00:00/f0 Emask 0x21 (host bus error) May 13 16:52:18 server1 kernel: [ 982.810687] ata1.01: status: { DRDY ERR } May 13 16:52:18 server1 kernel: [ 982.810750] ata1.01: error: { ABRT } May 13 16:52:18 server1 kernel: [ 982.858923] ata1.01: failed to IDENTIFY (I/O error, err_mask=0x2) May 13 16:52:18 server1 kernel: [ 982.858925] ata1.01: revalidation failed (errno=-5) May 13 16:52:18 server1 kernel: [ 982.858999] ata1: soft resetting link May 13 16:52:18 server1 kernel: [ 983.154718] ata1.01: failed to IDENTIFY (I/O error, err_mask=0x2) May 13 16:52:18 server1 kernel: [ 983.154721] ata1.01: revalidation failed (errno=-5) May 13 16:52:18 server1 kernel: [ 983.245935] ata3.00: exception Emask 0x50 SAct 0x0 SErr 0x480900 action 0x6 May 13 16:52:18 server1 kernel: [ 983.246016] ata3.00: BMDMA stat 0x26 May 13 16:52:18 server1 kernel: [ 983.246093] ata3: SError: { UnrecovData HostInt 10B8B Handshk } May 13 16:52:18 server1 kernel: [ 983.246159] ata3.00: failed command: WRITE DMA EXT May 13 16:52:18 server1 kernel: [ 983.246226] ata3.00: cmd 35/00:88:e7:c6:d1/00:00:36:00:00/e0 tag 0 dma 69632 out May 13 16:52:18 server1 kernel: [ 983.246227] res 51/84:79:e7:c6:d1/84:00:36:00:00/e0 Emask 0x70 (host bus error) May 13 16:52:18 server1 kernel: [ 983.246385] ata3.00: status: { DRDY ERR } May 13 16:52:18 server1 kernel: [ 983.246448] ata3.00: error: { ICRC ABRT } May 13 16:52:18 server1 kernel: [ 983.246525] ata3: hard resetting link May 13 16:52:19 server1 kernel: [ 983.722150] ata3: SATA link up 1.5 Gbps (SStatus 113 SControl 310) May 13 16:52:19 server1 kernel: [ 983.741542] ata3.00: failed to IDENTIFY (I/O error, err_mask=0x2) May 13 16:52:19 server1 kernel: [ 983.741545] ata3.00: revalidation failed (errno=-5) May 13 16:52:24 server1 kernel: [ 988.564390] ata1.01: both IDENTIFYs aborted, assuming NODEV May 13 16:52:24 server1 kernel: [ 988.564395] ata1.01: revalidation failed (errno=-2) May 13 16:52:24 server1 kernel: [ 988.564464] ata1.01: disabled May 13 16:52:24 server1 kernel: [ 988.564478] ata1: EH complete May 13 16:52:24 server1 kernel: [ 988.564495] sd 0:0:1:0: [sda] Unhandled error code May 13 16:52:24 server1 kernel: [ 988.564498] sd 0:0:1:0: [sda] Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK May 13 16:52:24 server1 kernel: [ 988.564502] sd 0:0:1:0: [sda] CDB: Write(10): 2a 00 01 2a 1d 6d 00 00 40 00 May 13 16:52:24 server1 kernel: [ 988.564509] end_request: I/O error, dev sda, sector 19537261 May 13 16:52:24 server1 kernel: [ 988.564566] sd 0:0:1:0: [sda] READ CAPACITY(16) failed May 13 16:52:24 server1 kernel: [ 988.564569] sd 0:0:1:0: [sda] Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK May 13 16:52:24 server1 kernel: [ 988.564572] sd 0:0:1:0: [sda] Sense not available. Board index The team • Delete all board cookies • All times are UTC + 1 hour [ DST ] Get VirtualBox Forum powered by phpBB © phpBB Group By any use of this Website, you agree to be bound by these Policies and Terms of Use Sponsored by The ongoing struggle I'll get there one day. « Paranoid, Init Has your CurrentCost ever done this? » Home file server / disk enclosure troubles On March 26th the file server here at home started resetting one of its ATA links over and over, in a couple of bursts each hour.

slimg00dy View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by slimg00dy Thread Tools Show Printable Version Email this Page Search this Thread Advanced Search Posting Rules You may not post new threads You may not post replies You may not post attachments You may not edit your posts BB code is On Smilies are On [IMG] code is Off HTML code is Off Forum Rules Similar Threads Thread Thread Starter Forum Replies Last Post Failing harddrive? I cannot get this problem to go away... I've been following dm-cache and bcache with interest.